macOS Agent Disconnects and Unable to Connect to Daemon
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macOS Agent Disconnects and Unable to Connect to Daemon

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Article ID: 402455

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Updated On:

Products

Carbon Black App Control

Issue/Introduction

A macOS agent is installed and connected, but later disconnects from the console. 

Symptoms:

  • When running any ./b9cli command the following is seen 
    Failed to connect to daemon
  • In the TraceSE.bt9 file, similar messages can be seen for binary version mismatch. 
    [ERR]2025-05-09 13:38:24 0x16b4f7000 : InitComm binary version mismatch Required[8.9.4] Requested[8.9.2]
    
    2025-04-15 21:44:40-06 <HOSTNAME> installd[976]: PackageKit: Skipping component "com.vmware.carbonblack.appc-es-loader" (8.9.2-8.9.2-*) because the version 8.9.4-8.9.4-* is already installed at /Applications/Bit9/Agent/appc-es-loader.app.
    2025-04-15 21:44:40-06 <HOSTNAME> installd[976]: PackageKit: Skipping component "com.bit9.b9notifier" (8.9.2-8.9.2-*) because the version 8.9.4-8.9.4-* is already installed at /Applications/Bit9/Agent/b9notifier.app.

Environment

  • Carbon Black Application Control: All Supported Versions
  • macOS: All Supported Versions
  • MDM

Cause

Software Distribution/MDM such as Jamf is attempting to downgrade the agent. 

Resolution

Update your MDM software with the package that is being used to install the agent. 

Upgrading macOS App Control Agents Using Jamf Pro (Big Sur+)

Jamf Pro (Big Sur+) Upgrade Instructions

Additional Information

  • Support does not assist with MDM profiling or software distribution setup. The instructions given are offered as guidance only.