non-ASCII characters in the exported environment XML file - \r\n \u00F1
search cancel

non-ASCII characters in the exported environment XML file - \r\n \u00F1

book

Article ID: 402451

calendar_today

Updated On:

Products

CA Identity Suite

Issue/Introduction

The exported environment settings file includes non-ASCII characters such as \n \u00F1, which leads to errors when trying to import the settings into another environment.
Here is a sample error from the XML file:

<PxParameter extraInfo="" index="5" uiType="TYPED">\n&lt;html&gt;\n  &lt;head&gt;\n     \n  &lt;/head&gt; \n  &lt;body&gt; \n    &lt;div&gt; \n      &lt;div&gt; \n        &lt;p class=\"TESt \"&gt;Test PX Policy\u00F1testing the special chars:\n...

Environment

Identity Manager v14.5.1

Cause

It was observed that after deploying HF-DE624003 and HF-DE623923 on top of 14.5 SP1, the exported environment settings file included non-ASCII characters.

Resolution

CHF1 was deployed on top of 14.5 SP1 + HF-DE624003 and HF-DE623923, which successfully resolved the issue.