Site Recovery Manager UI error - Unknown error
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Site Recovery Manager UI error - Unknown error

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Article ID: 402350

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Updated On:

Products

VMware Live Recovery

Issue/Introduction

Symptoms:

  • Event message on the Site Recovery UI page on the vCenter: "Site Recovery Manager UI error - Unknown error and The latest version of Site Recovery UI is not available.  Some functionality might be limited":

  • Event messaging started appearing after upgrading the vSphere replication and site recover manager appliance to version 9.0.2.2

Environment

  • vSphere replication version 9.0.2.2

  • Site Recovery Manager version 9.0.2.2

Cause

  • The IP address in the Certificate had an incorrect IP address which causes the certificate to fail.

  • From the vmware-dr.log, we see DNS lookup failed alerts: 
    --> (dr.fault.SitePairingFault) {
    -->    faultCause = (dr.fault.DnsLookupFault) {
    -->       faultCause = (vmodl.MethodFault) null,
    -->       faultMessage = <unset>,
    -->       address = "#####",
    -->       port = "443",
    -->       errorDescription = "DNS lookup failed."
    -->       msg = "Failed to look up the host name '####' in DNS."
    -->    },
    -->    faultMessage = <unset>,
    -->    name = "####",
    -->    uuid = "####"
    -->    msg = "Received SOAP response fault from [<SSL(<io_obj p:####, h:63, <TCP '####: 40416'>, <TCP '####: 443'>>), /drserver/vcdr/vmomi/sdk>]: remoteRecon>
    --> SRM server '####' cannot complete a pair operation. Failed to look up the host name '####' in DNS."
    --> }

  • dr-config.log
     DrRequestHandlerError:

    (drConfig.fault.DnsLookupFault) {
       faultCause = null,
       faultMessage = null,
       address = ####,
       port = 443,
       errorDescription = DNS lookup failed.
    }
            at java.base/jdk.internal.reflect.DirectConstructorHandleAccessor.newInstance(Unknown Source)
            at java.base/java.lang.reflect.Constructor.newInstanceWithCaller(Unknown Source)

Resolution

  • Permanent fix is to create a new certificate that contains the correct DNS and IP addresses.

  • Temporary work around - Change Site Recovery Manager and Replication Manager IP/DNS pointers to FQDN.

Additional Information