Robots do not show up after a hub restart
search cancel

Robots do not show up after a hub restart

book

Article ID: 402333

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) CA Unified Infrastructure Management On-Premise (Nimsoft / UIM) CA Unified Infrastructure Management SaaS (Nimsoft / UIM) DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

You have restarted a DX UIM hub and after the restart, the robots which normally appear attached to the hub are all missing in Infrastructure Manager (IM)/Admin Console.

 

Environment

  • DX UIM - any version
  • hub
  • robot

Cause

  • The exact cause is unknown but it may be more likely to occur after removing the robot.sds file from a hub.

Resolution

Steps:

  1. Stop the hub (e.g., "service nimbus stop" on Linux, or stop the 'Nimsoft Robot Watcher Service' on Windows)

  2. Wait 5 full minutes - not one second less!

  3. Start the hub (e.g. "service nimbus start" on Linux, or start the 'Nimsoft Robot Watcher Service' on Windows)

  4. The robots should then reappear within one minute.

  • When you stop the hub, the robots will get a "connection refused" message, and when this happens for 5 minutes in a row, they will go into a more aggressive reconnection mode which will force them to re-register with the hub and reappear.