Recreating VCHA after upgrading to vCenter 8.0 failed due to Insufficient disk space on datastore
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Recreating VCHA after upgrading to vCenter 8.0 failed due to Insufficient disk space on datastore

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Article ID: 402285

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

Symptoms:

  •  vCenter HA cannot be created due to invalid configuration

  • You may see an error within the vpxd.log file:
    YYYY-MM-DDThh:mm:ss.944Z error vpxd[28133] [Originator@6876 sub=vpxLro opID=mbw0dssj-5421-auto-46m-h5:70001562] [VpxLRO] Unexpected Exception: N3Vim5Fault11NoDiskSpace9ExceptionE(Fault cause: vim.fault.NoDiskSpace
    --> )
    --> [context]zKq7AVECAQAAAPONbgEWdnB4ZAAAowFTbGlidm1hY29yZS5zbwAA/gdCAB8vQwCMiUqBU0U6AWxpYnZpbS10eXBlcy5zbwCBfmM6AYFU9joBgYz5OgGC+64rAnZweGQAgia7KwKCPkkpAoI/jSkCgnsSKgKCsKCAAoL7sIACgu/DfwKC3pqAAgAE3DcAFzU4A
    Lv/UAOwjgBsaWJwdGhyZWFkLnNvLjAABO/6D2xpYmMuc28uNgA=[/context]
    YYYY-MM-DDThh:mm:ss.948Z error vpxd[28133] [Originator@6876 sub=FailoverClusterOperator opID=mbw0dssj-5421-auto-46m-h5:70001562] Exception: N5Vmomi11MethodFault9ExceptionE(Fault cause: vim.fault.NoDiskSpace
    --> )
    --> [context]zKq7AVECAQAAAPONbgEPdnB4ZAAAowFTbGlidm1hY29yZS5zbwAA/gdCAB8vQwCMiUqB0GIrAnZweGQAga6hgAKBz6SAAoE/sYACge/DfwKB3pqAAgAE3DcAFzU4ALv/UAKwjgBsaWJwdGhyZWFkLnNvLjAAA+/6D2xpYmMuc28uNgA=[/context]
    YYYY-MM-DDThh:mm:ss.949Z info vpxd[28133] [Originator@6876 sub=vpxLro opID=mbw0dssj-5421-auto-46m-h5:70001562] [VpxLRO] -- FINISH task-445
    YYYY-MM-DDThh:mm:ss.949Z error vpxd[28133] [Originator@6876 sub=Default opID=mbw0dssj-5421-auto-46m-h5:70001562] [VpxLRO] -- ERROR task-445 --  -- Datacenters -- com.vmware.vcenter.vcha.cluster.deploy: :vim.fault.NoDiskSpace
    --> Result:
    --> (vim.fault.NoDiskSpace) {
    -->    faultCause = (vmodl.MethodFault) null,
    -->    faultMessage = (vmodl.LocalizableMessage) [
    -->       (vmodl.LocalizableMessage) {
    -->          key = "com.vmware.vim.datastore.error.noSpaceExtendedInfo",
    -->          arg = (vmodl.KeyAnyValue) [
    -->             (vmodl.KeyAnyValue) {
    -->                key = "requiredSpace",
    -->                value = 4629768175616
    -->             },
    -->             (vmodl.KeyAnyValue) {
    -->                key = "freeSpace",
    -->                value = 1340861317120
    -->             }
    -->          ],
    -->          message = "Required space: 4629768175616. Available space: 1340861317120."
    -->       }
    -->    ],
    -->    file = "[Data_Store_Name] Prodastvc_8/Prodastvc_8_16.vmdk",
    -->    datastore = "Data_Store_Name"
    -->    msg = "Insufficient disk space on datastore 'Data_Store_Name'."
    --> }
    --> Args:
    -->

Environment

VMware vCenter Server Appliance 8.x

Cause

This issue is caused by insufficient disk space on datastore where the vCenter VMs are deployed.

The new VM was created with thick provision type and was causing too much space to be used, causing the VCHA failure when copying to the same datastore.

Resolution

Deployed the new vCenter's VMs with a thin provision type.