HCX Manager "Failed to download upgrade bundle"
search cancel

HCX Manager "Failed to download upgrade bundle"

book

Article ID: 402272

calendar_today

Updated On:

Products

VMware Cloud on AWS VMware HCX

Issue/Introduction

The following error message is displayed in HCX 443 UI or plugin when the user tries to download the upgrade bundle from either the HCX Connector or Cloud Manager:
Failed to download upgrade bundle: Cannot build a download URL Not able to generate token.

Cause

External image depot server (hybridity-depot.broadcom.com) was decommissioned effective 2nd May 2025, used by HCX systems for download/upgrade.

Resolution

Please follow one of the below options based on the environment:

  • On-prem Customers:
    If you have a Broadcom support account with valid entitlements:
    Visit support.broadcom.com.
    • Log in with your credentials.

    • Navigate to the HCX product section to download the HCX OVA and the required upgrade bundles.

    • Follow Upgrade HCX Manager for Local Sites to upgrade HCX Manager.

  • Hyperscaler Customers:
    If you are using HCX through a hyperscaler environment

    • Please contact your respective hyperscaler provider to obtain the HCX OVA and upgrade bundles.

    • Once you download the upgrade bundle to your local machine, upload the bundle to HCX manager using the HCX Appliance Management (:9443 UI) and then perform an upgrade.

    • Follow Upgrade HCX Manager for Local Sites to upgrade HCX Manager.

  • VMC (VMware Cloud on AWS) Customers:
    If you are using HCX through a VMC SDDC , you need to do it via VMware Cloud Console:

Additional Information