Windows server cloud template is taking APIPA (169.#.#.#) IP addresses instead of IP from Infoblox or other IPAM integrations.
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Windows server cloud template is taking APIPA (169.#.#.#) IP addresses instead of IP from Infoblox or other IPAM integrations.

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Article ID: 402218

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • After creating a new windows template and adding it to an existing blueprint, Aria Automation customization is not assigning an IP Address.
  • You are using a Customization Spec in vCenter 
  • Existing templates are working as expected
  • There may be no errors in Automation, depending on how your IP customization is configured

Environment

Aria Automation 8.x

Microsoft Windows OS Templates.

Microsoft.MicrosoftEdge.Stable package

Cause

Sysprep and Guest Customization in vCenter is not completing, which prevents the VM from rebooting and kicking off the Customization from Aria Automation. 

In many cases, an Application such as Edge will cause sysprep to fail. 

Resolution

  1. Review the %windir%System32\Sysprep\Panther\setupact.log for errors and fix the issue that is causing sysprep to fail.  In the case of Edge causing the failure you will see an error similar to this: SYSPRP Package Microsoft.MicrosoftEdge.Stable_120.0.2210.91 was installed for a user, but not provisioned for all users. This       package will not function in the sysprep image. SYSPRP Failed to remove apps for the current users: 0x80073cf2.

  2. Remove the Package from the template using Powershell commands
    1. In the template, run Powershell as an Administrator
    2. Execute this command:
      Get-APPXPackage Microsoft.MicrosoftEdge.Stable
    3. Use the PackageFullName from the output of Step 2 and run command Remove-AppxPackage -Package <PackageFullName>
      Example:  Remove-AppxPackage -Package Microsoft.MicrosoftEdge.Stable_139.0.3405.111_neutral__8wekyb3d8bbwe 
    4. Convert the VM back to a template
    5. Try your deployment again

Additional Information

Note: the same issue can occur on other Windows versions and for other applications. The error in %windir%System32\Sysprep\Panther\setupact.log should indicate why sysprep is failing.