MUX - Error When Clicking the Notifications Bell Icon.
search cancel

MUX - Error When Clicking the Notifications Bell Icon.

book

Article ID: 402208

calendar_today

Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

When clicking the Notifications icon in MUX, the following error gets thrown, "API-1019 : Could not process the request due to internal error."

Environment

Clarity 16.3.x

Cause

ERROR 2025-05-29 15:52:18,655 [https-jsse-nio2-443-exec-4877] ppm.rest (clarity:some_user:session_id:PPM_REST_API) (sessionid) Exception processing request for resource [pullNotifications], query string [/private/pullNotifications?limit=9&offset=0&_cb=1748548338416]
java.lang.NullPointerException: Cannot invoke "Object.toString()" because the return value of "java.util.HashMap.get(Object)" is null

Resolution

Upon analysis performed for the queries that are executed for the action that pulls Notifications it was determined that some old timesheet related notification getting selected and since those are not MUX generated notifications system did not know how to handle those so we needed to purge these old notifications using an out of the box job called "Purge Notifications".