Upgrade Stuck at: Configuring step 13 of XX - Altiris Task Management Installation...
search cancel

Upgrade Stuck at: Configuring step 13 of XX - Altiris Task Management Installation...

book

Article ID: 402182

calendar_today

Updated On:

Products

IT Management Suite Client Management Suite

Issue/Introduction

You are trying to upgrade ITMS to version 8.8.

The MSI installation seems to be going just fine. As soon as SIM (Symantec Installation Manager) is configuring, it gets stuck at:

Configuring task 13 of 99: Configuring Altiris Task Management Installation...
-----------------------------------------------------------------------------------------------------
Process: SymantecInstallationManager (15156), Thread ID: 29, Module: SymantecInstallationManager.exe
Priority: 4, Source: Symantec.Installation.Automation.Output.ReportInfo

 

As far as you can tell, the upgrade is moving, slowly, but still moving. You can see that previous steps for this configuration section were completed:

Operation completed: Updating Package Distribution points for product agent plugins'Altiris Task Management' (9f9a80fc-2d71-4b08-a1ad-fb146b4af2c6), (100%) 2/2 [8,73 i/s], applied=1, total time=0:00:00,23
-----------------------------------------------------------------------------------------------------

Process: AeXSvc (14160), Thread ID: 25, Module: Altiris.NS.StandardItems.dll
Priority: 4, Source: ProductInstallationHelper

 

When you look at SQL Management Studio under Activity Monitor > Active Expensive Queries,

you can see most of the time it's just running this:

SELECT ir.ParentItemGuid, ir.ChildItemGuid, ir.Hint, ir.ReferenceType, ir.CreatedDate, ir.ModifiedDate
    FROM ItemReference ir
        left join vInstalledItem vp on @ParentItemGuid is not null and vp.[Guid] = ir.ChildItemGuid
        left join vInstalledItem vc on @ChildItemGuid is not null and vc.[Guid] = ir.ParentItemGuid
    where   (@ParentItemGuid is null or (ir.ParentItemGuid = @ParentItemGuid and vp.[Guid] is not null))
        and (@ChildItemGuid is null or (ir.ChildItemGuid = @ChildItemGuid and vc.[Guid] is not null))
        and (@Hint is null or ir.Hint = @Hint)

Environment

During Upgrade to ITMS 8.8

Cause

Slow performance for "spGetItemReferences" stored procedure (SP) due to some changes added to it for the ITMS 8.8 release.

Resolution

This issue has been reported to our Dev team. Currently a fix is targeted to be added to our ITMS 8.8.1 release.

Quick workaround is:

  • If upgrade is still running - apply this SP below from SQL studio (this is the original version used prior to 8.8 release). SP can be altered during on-going upgrade from within SQL Studio.
    It will alter "SpGetItemReferences" reverting back newer changes introduced under ITMS 8.8 release. 

    Note: this SP can be applied as well after upgrade completion, if slow performance by "SpGetItemReferences" is noticed.

/*
Copyright (c) 2025 Broadcom. All Rights Reserved. The term "Broadcom" refers to Broadcom Inc. and/or its subsidiaries. 
All trademarks, trade names, service marks, and logos referenced herein belong to their respective companies.

This software and all information contained therein is confidential and proprietary and shall not be duplicated, 
used, disclosed or disseminated in any way, without the express written permission of Broadcom, 
except as authorized by a valid, in effect license from Broadcom. 
All authorized reproductions must be marked with this language.

EXCEPT AS SET FORTH IN THE APPLICABLE LICENSE AGREEMENT, TO THE EXTENT PERMITTED BY APPLICABLE LAW AND EXCEPT 
AS AGREED BY BROADCOM IN ITS APPLICABLE LICENSE AGREEMENT, BROADCOM PROVIDES THIS DOCUMENTATION "AS IS" 
WITHOUT WARRANTY OF ANY KIND, INCLUDING WITHOUT LIMITATION, ANY IMPLIED WARRANTIES OF MERCHANTABILITY, 
FITNESS FOR A PARTICULAR PURPOSE, OR NONINFRINGEMENT. IN NO EVENT WILL BROADCOM BE LIABLE TO THE END USER 
OR ANY THIRD PARTY FOR ANY LOSS OR DAMAGE, DIRECT OR INDIRECT, FROM THE USE OF THIS DOCUMENTATION, 
INCLUDING WITHOUT LIMITATION, LOST PROFITS, LOST INVESTMENT, BUSINESS INTERRUPTION, GOODWILL, 
OR LOST DATA, EVEN IF BROADCOM IS EXPRESSLY ADVISED IN ADVANCE OF THE POSSIBILITY OF SUCH LOSS OR DAMAGE.
*/
 
ALTER PROC [dbo].[spGetItemReferences]
    @ParentItemGuid uniqueidentifier = NULL,
    @ChildItemGuid  uniqueidentifier = NULL,
    @Hint           nvarchar(100)    = NULL
AS
BEGIN
    IF @ParentItemGuid = 0x0
        SET @ParentItemGuid = NULL
    IF @ChildItemGuid = 0x0
        SET @ChildItemGuid = NULL

    IF ( @ParentItemGuid IS NULL AND @ChildItemGuid IS NULL AND @Hint IS NULL )
    BEGIN
        RAISERROR('spGetItemReferences: At least one parameter should be not null', 16, 1)
        RETURN
    END

    DECLARE @Query nvarchar(4000)

    SET @Query = ' SELECT ir.ParentItemGuid, ir.ChildItemGuid, ir.Hint, ir.ReferenceType, ir.CreatedDate, ir.ModifiedDate ' +
                 '     FROM ItemReference  AS ir '

    IF ( @ParentItemGuid IS NULL )
        SET @Query = @Query + ' JOIN vInstalledItem AS viip WITH(readcommitted) ON viip.Guid = ir.ParentItemGuid '
    IF ( @ChildItemGuid IS NULL )
        SET @Query = @Query + ' JOIN vInstalledItem AS viic WITH(readcommitted) ON viic.Guid = ir.ChildItemGuid '

    SET @Query = @Query + ' WHERE 1 = 1 '

    IF ( @ParentItemGuid IS NOT NULL )
        SET @Query = @Query + ' AND ir.ParentItemGuid = @ParentItemGuid '
    IF ( @ChildItemGuid IS NOT NULL )
        SET @Query = @Query + ' AND ir.ChildItemGuid = @ChildItemGuid '

    IF ( @Hint IS NOT NULL )
    BEGIN
        SET @Hint = LOWER( @Hint )
        SET @Query = @Query + ' AND LOWER(ir.Hint) = @Hint '
    END

    EXEC sp_executesql @Query, N'@ParentItemGuid uniqueidentifier, @ChildItemGuid uniqueidentifier, @Hint nvarchar(100)', @ParentItemGuid, @ChildItemGuid, @Hint
END