Error: "500 INTERNAL_SERVER_ERROR class java.lang.NullPointerException" for GET cloudapi/1.0.0/orgVdcNetworks VCD OpenAPI request
search cancel

Error: "500 INTERNAL_SERVER_ERROR class java.lang.NullPointerException" for GET cloudapi/1.0.0/orgVdcNetworks VCD OpenAPI request

book

Article ID: 402155

calendar_today

Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • Continuous java.lang.NullPointerException Events triggered by Operations Manager Cloud Proxy Requests to Cloud Director(VCD).
  • Attempting to make a GET cloudapi/1.0.0/orgVdcNetworks VCD OpenAPI request fails with an error of the form:

    500 INTERNAL_SERVER_ERROR class java.lang.NullPointerException

  • The /opt/vmware/vcloud-director/logs/vcloud-container.debug.log files on the Cells show errors of the form:

    | ERROR    | pool-jetty-#             | DefaultExceptionMapper         | Internal server exception | requestId=########-####-####-####-############,request=GET https://<vcd_address>/cloudapi/1.0.0/orgVdcNetworks,requestTime=####,remoteAddress=#.#.#.#:####,userAgent=####,accept=application/json;version 39.1
    java.lang.NullPointerException
            at com.vmware.vcloud.networking.model.network.converter.OrgVdcNetworkDbToCloudApiConverter.setOwnerAndOrgFromVdcGroup(OrgVdcNetworkDbToCloudApiConverter.java:123)
            at com.vmware.vcloud.networking.model.network.converter.OrgVdcNetworkDbToCloudApiConverter.createNetworkFromLogicalResourceModel(OrgVdcNetworkDbToCloudApiConverter.java:105)
            at com.vmware.vcloud.networking.model.network.converter.OrgVdcNetworkDbToCloudApiConverter.convert(OrgVdcNetworkDbToCloudApiConverter.java:72)
            at com.vmware.vcloud.networking.dao.NetworkDao.toVdcNetworkPage(NetworkDao.java:669)
            at com.vmware.vcloud.networking.dao.NetworkDao.getAllOrgVdcNetworks(NetworkDao.java:639)

Environment

VMware Cloud Director 10.6.1.x

Cause

This issue occurs if there is a stale network in Cloud Director which is part of a Data Center Group and Organization which no longer exist.

Resolution

To resolve this issue the stale network will need to be identified and removed if it is no longer in use.
As this may require changes to the Cloud Director Database, contact Broadcom Support and note this Article ID (402155) in the problem description.
For more information, see
Creating and managing Broadcom support cases.