Discovery Profiles in CA Performance Management (CAPM) not running, instead going into "Queued" state
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Discovery Profiles in CA Performance Management (CAPM) not running, instead going into "Queued" state

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Article ID: 401994

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Updated On:

Products

Network Observability CA Performance Management

Issue/Introduction

Spectrum Default Domain GC has many devices but the Default IP Domain in PM corresponding to it has much fewer. Creating Discovery Profiles to manually discover the devices that hadn't been pushed across from Spectrum doesn't appear to work, instead they go into a state of "Queued" when run:


 

Creating a new DP with a single IP and address and then manually running it gives the same result, goes into "Queued" state.

 

Looking at the DA karaf.log, we see the following:

2025-03-23 17:30:49,0462025-03-23T17:30:49,046 | ERROR | ExceptionLog | A NEW application exception occurred (Key=90f17564c15aa524ec754620a88ce1245192fbe7) : Cannot invoke "com.ca.im.core.datamodel.inventory.DiscoveryCompletionStatus.toString()" because "errCode" is null | (ExceptionLogger.java:108) 
java.lang.NullPointerException: Cannot invoke "com.ca.im.core.datamodel.inventory.DiscoveryCompletionStatus.toString()" because "errCode" is null
    at com.ca.im.tm.inventory.event.impl.InventoryDiscoveryResultsPublisherImpl.generateFailedEvent(InventoryDiscoveryResultsPublisherImpl.java:135) ~[?:?]
...

Environment

DX NetOps CAPM 24.3.1 - 24.3.10

Cause

This exception was not handled in the code. So when it happens, the number of the running discovery was not decremented and eventually it reaches the limit and caused the rest of the discoveries to be queued.

Resolution

This is fixed in CAPM release 24.3.11 so upgrade to 24.3.11 or later will resolve this.