Exit Code exit code 1603 (0x643)- 'Fatal error during installation' when installing patch vs2022_Enterprise_17.14.4.exe
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Exit Code exit code 1603 (0x643)- 'Fatal error during installation' when installing patch vs2022_Enterprise_17.14.4.exe

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Article ID: 401946

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Updated On: 06-23-2025

Products

Client Management Suite

Issue/Introduction

Unable to install the Visual Studio 2022 June 2025 update and the error received in the Sym Agent log is:

Command [STDeploy.exe package="C:\ProgramData\Symantec\Patch\staging\deploy-package.zip" sandboxesDir="C:\ProgramData\Symantec\Patch" logsDir="C:\Program Files\Altiris\Altiris Agent\Agents\SoftwareManagement\Software Delivery\{BCDE5672-A93B-2335-477F-D8DF71F0BB73}\cache" patchStore="C:\Program Files\Altiris\Altiris Agent\Agents\SoftwareManagement\Software Delivery\{BCDE5672-A93B-2335-477F-D8DF71F0BB73}\cache"] executed with exit code 1603 (0x643)- 'Fatal error during installation'

The application install log file dd_setup_20250613100309_errors.log was found in the C:\Windows\SystemTemp folder and this included some helpful information that included:

Package 'Microsoft.VisualStudio.Branding.Enterprise,version=17.14.36017.23,language=en-US,productarch=x64' failed to download from ''.
    Search URL
        https://aka.ms/VSSetupErrorReports?q=PackageId=Microsoft.VisualStudio.Branding.Enterprise;PackageAction=DownloadPackage;ReturnCode=0x80070005
    Details
        Access to the path '\\<NetworkShare>\Visual Studio 2022\Enterprise\Microsoft.VisualStudio.Branding.Enterprise,version=17.14.36017.23,language=en-US,productarch=x64\payload.vsix' is denied.

Visual Studio updates worked fine until the May and June 2025 updates were released.

Environment

ITMS 8.7.3

Patch Management 8.7.3

Cause

The application install log included the error below and shows that the "<NetworkShare>" not available to the application installer to finish the installation as seen below:

Access to the path '\\<NetworkShare>\Visual Studio 2022\Enterprise\Microsoft.VisualStudio.Branding.Enterprise,version=17.14.36017.23,language=en-US,productarch=x64\payload.vsix' is denied.

Resolution

Worked with the Visual Studio team as well as the network team to resolve the configuration permissions to allow the installation to complete.