Host go not responding intermittently after upgrade when using Self-signed certificates
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Host go not responding intermittently after upgrade when using Self-signed certificates

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Article ID: 401942

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Updated On:

Products

VMware vSphere ESXi VMware vCenter Server 8.0

Issue/Introduction

1. Host becomes unresponsive intermittently in vCenter

2. Host client cannot be accessed

3. Restarting all services on the host (services.sh restart) will make the host stable for sometime before going into a not responding state again

4. Envoy logs are showing exceeded max allowed: 128

/var/run/log/envoy-access.log

envoy.log:2025-06-02T20:34:56.255Z In(166) envoy[########]: "2025-06-02T20:34:55.052Z warning envoy[########] [Originator@6876 sub=filter] [Tags: "ConnectionId":"181200"] closing connection TCP<###.###.###.###:44340, ###.###.###.###:443>"

Environment

ESXi

vCenter

Cause

Connections to envoy service on the host do not release properly after an upgrade.

Resolution

Re-issue the certificates to the hosts from vCenter using Certificate Manager

Workaround:

Log into host via SSH, Restart management agents, https://knowledge.broadcom.com/external/article/320280/restarting-the-management-agents-in-esxi.html, In vCenter, then disconnect and reconnect host.