Error "Http failure response for <https://eapi.broadcom.com>/vcf/ums/api/v1/usage-metering-agents/#####-#####-####-####/oauth-app: 409 OK" when attempting to generate access token for Usage Meter from VCF Business Services console
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Error "Http failure response for <https://eapi.broadcom.com>/vcf/ums/api/v1/usage-metering-agents/#####-#####-####-####/oauth-app: 409 OK" when attempting to generate access token for Usage Meter from VCF Business Services console

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Article ID: 401838

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Updated On:

Products

VMware Usage Meter

Issue/Introduction

  • Following error is reported when trying to generate access token for Usage Meter instances from VCF Business Services console 




  • Reviewing the registered Usage Meter(UM) instances, it was noticed that there were more than one UM instances registered with same name

Environment

VCF usage meter
vCloud Usage Meter

Cause

This issue occurs when there are more than one Usage Meter(UM) instance registered with same name. This was allowed before UM 9.0 release where multiple UMs could be registered with same name

Resolution

To resolve this issue, change the label of affected Usage Meter instance and ensure they are registered with unique names by editing its settings - Edit the VCF Usage Meter Settings in the VCF Business Services Console