Error "Load Balancer Cloud cloud-<id> does not exist" when attempting to view or edit NSX edge gateway Load Balancer in VCD
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Article ID: 401813
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Updated On:
Products
VMware Cloud Director
Issue/Introduction
When attempting to view or update / disable or delete the Edge Gateway settings from VCD Provider Portal > Resources > Cloud Resources > Edge Gateways > Edge Gateway > Load Balancer > General Settings > Edit / Delete failing with error : Load Balancer Cloud cloud-<Edge-gateway-LB-entity-id> does not exist.
The NSX edge gateway was modified directly in recent times.
Environment
VMware Cloud Director 10.x
Cause
This issue occurs because NSX edge gateway elements ( Load balancers / pools ) were removed outside of Cloud Director, leaving Cloud Director unaware of the deletion.
Consequently, it attempts to retrieve information for objects that no longer exist
Resolution
This is not an issue with VMware Cloud Director, but a result of configuration changes (deletions) made outside of the scope of Cloud Director. Please review the Workaround section for an applicable solution.
Workaround:
Cloud Director API Explorer
Login to the Cloud Director Portal as a user with valid rights to delete load balancer pools.
In the top right of the page, click on the Help dropdown.
Click API Explorer.
Locate the edgeGatewayLoadBalancer section.
Click the GET function and select Try it out. Validate the ID for the entity to disable.
Click the PUT function and select Try it out.
Edit the json form the PUT request and set the disabled field as false and leave all other fields with the value from GET request or you may leave them blank. Click Submit. .
Repeat for any additional Loadbalancer which were deleted outside of Cloud Director.
refresh the VCD portal, validate that we are now able to view / edit / delete the edge gateway configurations.