VMs lose network connectivity after upgrading NSX to 9.x
search cancel

VMs lose network connectivity after upgrading NSX to 9.x

book

Article ID: 401782

calendar_today

Updated On:

Products

VMware NSX

Issue/Introduction

  • NSX is upgraded from version 4.x to 9.x via the NSX UI (not via VCF UI)
  • VMs have network connectivity issues post-upgrade (inaccessible remotely)

Environment

  • Upgraded VMware NSX 9.x that is not part of a VCF installation
  • VMs are connected to VDS portgroups, not NSX-backed segments

Cause

Upgrading NSX 4.x to 9.x via the NSX UI (outside of a VCF installation) is not supported.

Resolution

NSX 4.x must be imported into VCF prior to being upgraded. See Direct upgrade of NSX 4.x to NSX 9.x is not supported for more details.

If this issue is encountered, a new NSX instance must be deployed/configured and the proper upgrade path utilized. Restoring NSX from a backup taken prior to the 9.x upgrade can help to speed up the recovery.

Additional Information