Error while opening metrics in Real Time Performance Viewer for some computers
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Error while opening metrics in Real Time Performance Viewer for some computers

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Article ID: 401691

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Updated On:

Products

IT Management Suite

Issue/Introduction

After enabling and targeting computers with a Monitor policy, some computers will throw an error when attempting to view the metrics in the Real-Time Performance Monitor Viewer (Actions > Monitor > Real-Time)

  • Real-Time Performance Viewer Error:
    • Failed to connect the Monitor Plug-in. The Monitor Plug-in Service may be initializing or not running. Please retry in a few minutes and verify that Monitor Service is installed and running on the machine.
  • Notification Server (NS) log Error:
    • MainController failure.
    • Failed to connect the Monitor Plug-in. The Monitor Plug-in Service may be initializing or not running. Please retry in a few minutes and verify that Monitor Service is installed and running on the machine.
         [AeXException @ Altiris.Monitor.Api.dll]
  • Verified that port 1011 is open on the targeted computers, the NS, and Site Servers (for agentless monitoring)
  • Verified that the targeted computers had the Monitor Solution agent and had received the Monitor policy
  • Ran a command to check the port from the targeted computers and the NS, and from the NS to the targeted computers. 

Cause

The checks between the targeted computers and the NS failed, indicating that an intermediate device (switch, router, etc) was blocking traffic through port 1011.

Resolution

Work with the networking team to identify intermediate devices that are blocking port 1011 traffic and enable this traffic.