SDDC - ESXi Service Account - Password remediate for resource fails after applying custom password length on host
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SDDC - ESXi Service Account - Password remediate for resource fails after applying custom password length on host

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Article ID: 401681

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Updated On:

Products

VMware SDDC Manager

Issue/Introduction

Custom password policy was applied to ESXi hosts, then SDDC password remediation failed.  Password shows "disconnected".

 

Validation of password of ESXi host: has failed

Environment

SDDC 5.2.x

 

Cause

Custom password policy was applied to ESXi hosts, then password remediation failed.  This was due to the mismatch between the length requirement and the actual password length.

Resolution

Workaround:

  • Remove the custom password requirements from the ESXi host.
  • Retrieve the service accounts credentials from SDDC Manager
  • SSH into the ESXi host as root
  • Update the service account password to match SDDC database
         passwd svc-vcf-labwld1vxr05
  • Clear any password lockouts
         pam_tally2 -u svc-vcf-labwld1vxr05 -r 
  • SSH into the ESXi host with the service account 
  • Run a password remediation from SDDC towards the service account.

Additional Information