Workpoint log message written every 5 minutes in IM Server log
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Workpoint log message written every 5 minutes in IM Server log

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Article ID: 401647

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Updated On:

Products

CA Identity Manager CA Identity Suite

Issue/Introduction

We are seeing a lot of com.workpoint.server.ServerProperties log entries in the server.log file. I'm not sure how to shut this off or tone it down. I don't want to have this logging all of these entries once we get to Prod as it will have enough log entries as it is. How do I adjust the logging level to mute these entries?

Here are a few examples of the entries:

2025-04-22 12:26:57,952 INFO [com.workpoint.server.ServerProperties] (pool-25-thread-1) ServerProperties.setProperty() invoked for property= calculated.db.offset.millis.WPDS, value=0

2025-04-22 12:31:58,048 INFO [com.workpoint.server.ServerProperties] (pool-24-thread-1) ServerProperties.setProperty() invoked for property= calculated.db.offset.millis.WPDS, value=8

2025-04-22 12:36:58,092 INFO [com.workpoint.server.ServerProperties] (pool-24-thread-1) ServerProperties.setProperty() invoked for property= calculated.db.offset.millis.WPDS, value=-12

Environment

Identity Manager 14.5.x

Cause

The message appears every 5 minutes and is related to running of the Workpoint Monitors since a test with the monitors set with autostart=false did not trigger the message upon IM restart automatically. The Workpoint Monitors are required, otherwise IM will not be able to fetch fresh/runtime data of a user's worklist and an exception will be seen on the "View My Worklist" screen.

Resolution

The messages are triggered by the Workpoint Monitors and since the Workpoint Monitors are required the messages cannot be removed or suppressed.