External Security Exit failing with Access Denied with Web Viewer 12.1
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External Security Exit failing with Access Denied with Web Viewer 12.1

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Article ID: 401625

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Updated On:

Products

Output Management Web Viewer OM View ACF2

Issue/Introduction

An External Security Exit was configured for Web Viewer 12.1. Users could not log in when the External Security Exit was in place in the CAOMWV12_HOME"\config\ directory.  

Environment

  • OM Web Viewer 12.1
  • OM View 14.0
  • ACF2

Cause

SECURITY=INTERNAL is required with OM View when using an External security Exit with Web Viewer 12.1

Resolution

The External Security Exit itself was working.

With logging enabled, there was an error message from ACF2 blocking access. It was necessary to reconfigure OM View to use SECURITY=INTERNAL when using an External Security Exit with Web Viewer 12.1.

After setting OM View to use Internal Security, users were able to log on.

 

Additional Information

To turn on logging:
There is a configuration file called "SecurityExitUsers.properties" located in "CAOMWV12_HOME"\config\ directory. 
In that file should be a property which should be set to true:  

    # Turn debug messages On/OFF
    CONFIG.debug=true

The logs all go to System Out so they are located in the Tomcat log once the server starts up.

Web viewer 12.1 Documentation Reference: Code the External Security Exit