After a ESXi outage resulting in an ESXi Host being permanently offline (e.g. due to Hardware failure),
VM(s) registered on this Host are showing as "disconnected" in the vSphere Web Client and therefore cannot be managed.
Example:
Environment
ESXi 7.x
ESXi 8.x
Cause
VM(s) showing as disconnectedbecause the Host on which the VM(s) is registered on is not connected to vCenter (= showing as "Not responding")
Resolution
In order to manage the VM(s) while the Host is offline:
Option 1
For the time, the affected Host is offline and/or not being able to re-connect to vCenter: Remove the Host from Inventory by right-clicking the Host and select "Remove from Inventory" from the pop-up menu.
Follow the steps outlined in KB 335224 to register the affected VM(s) on one of the other Hosts which are online
Option 2
Login to different Host Client UI of the ESXi Host which is online.
Click Storage in the VMware Host Client inventory.
Right-click a datastore from the list and click Register a VM.
Select the virtual machine you want to register from the list and click Register.