ConnectALL Services won't start due to error "com.go2group.connectall.config.DBConfig: Error connecting to Database"
search cancel

ConnectALL Services won't start due to error "com.go2group.connectall.config.DBConfig: Error connecting to Database"

book

Article ID: 401517

calendar_today

Updated On:

Products

ConnectAll On-Prem ConnectALL

Issue/Introduction

The Orphan, Scheduler and Core ConnectAll services on the server have gone down and can't be restarted. Rebooting the server didn't help.

Environment

3.7.x

Cause

Upon checking the logs for respective services, found that the database connections is an issue.
This has happened after the patch on the Postgres database. Resolving the connection issue on Postgres database resolved the issue.


ERROR 2025-06-11 03:35:30,033 [ | | | | {}][housekeepingScheduler-1] com.go2group.connectall.config.DBConfig: Error connecting to Database.
java.sql.SQLTransientConnectionException: hikariCP - Connection is not available, request timed out after 30002ms.
at com.zaxxer.hikari.pool.HikariPool.createTimeoutException(HikariPool.java:696) ~[HikariCP-4.0.3.jar!/:?]
.
at java.base/java.lang.Thread.run(Thread.java:829) [?:?]
Caused by: org.postgresql.util.PSQLException: Connection to <database_hostname>:<port> refused. Check that the hostname and port are correct and that the postmaster is accepting TCP/IP connections.
 

Resolution

Restart ConnectALL services after addressing Postgres database connection issue from ConnectALL server.