Primary Node fails to display configuration value on 'Cluster' menu of Aria Operations for Logs
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Primary Node fails to display configuration value on 'Cluster' menu of Aria Operations for Logs

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Article ID: 401436

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • In the 'Cluster' menu, on the 'Management' tab, when clicking on the Primary node, the pop-up window shows all details as 'not available' as per the screenshot below.
  • The primary node is identified by its FQDN on the 'Cluster' screen.

Environment

Aria Operations for Logs 8.x

Cause

The information displayed on the pop-up window is gathered by API call. In some cases, there are issues using the FQDN for API calls.

Resolution

Update the internal configuration document to use the IP address instead of the FQDN.

  • Navigate to '<Ops_for_logs_FQDN>/internal/config'
  • In the '<distributed overwrite-children="true">' section, the first entry should be identified as '<service-group name="standalone" />', and the value of 'daemon host' will be equal to the primary node FQDN.
  • Replace the FQDN with the IP for the primary node.
  • Hit the 'Save' button and allow a few minutes for the change to propagate to all nodes; no steps are required for this to happen.
  • Return to the 'Cluster' menu and confirm that the primary node is identified by FQDN and that the details now show in the popup window.