Error: "fail to login to web-engine, error code: 401, error: %!w(<nil>)" when attempting to upgrade a workload cluster
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Error: "fail to login to web-engine, error code: 401, error: %!w(<nil>)" when attempting to upgrade a workload cluster

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Article ID: 401393

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Updated On:

Products

VMware Telco Cloud Automation

Issue/Introduction

  • TCA is, or at some point was, integrated with Active Directory
  • Workload cluster upgrades via TCA fail with the below error:

    error: fail to login to web-engine, error code: 401, error: %!w(<nil>)

 

Environment

3.2

Cause

  • The AD bind account's username contains a space (" ").
  • Usernames with spaces are not handled properly.

Resolution

Use a bind account for the Active Directory integration that does not have a space.

Additional Information

It is possible that Active Directory is initially configured, but the environment is later reconfigured to use SSO. This reconfiguration should remove the AD configuration, however in some scenarios it may be possible it is not properly cleaned up. This can result in both AD and SSO being configured in the TCA database. If you are receiving this error and have changed from AD to SSO as the authentication source, submit a case with support for assistance cleaning this up.