Error: "Unable to connect to the Proxy Server" - VCF Download Tool is failing with proxy configured.
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Error: "Unable to connect to the Proxy Server" - VCF Download Tool is failing with proxy configured.

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Article ID: 401383

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Updated On:

Products

VMware SDDC Manager

Issue/Introduction

VCF Download Tool (VCFDT) fails with a proxy configured.

"Unable to connect to Proxy Server" is encountered when running download operations:

./vcf-download-tool metadata download --depot-store /nfs/vmware/vcf/nfs-mount/depot-test --depot-user [email protected] --depot-user-password-file=pwd.txt --proxy-server xxxxxx.xxxx.xxx:3128

*********Welcome to VMware Cloud Foundation Download Tool***********

[YYYY-MM-DDTHH:MM:SS]  INFO   --- [           main] com.vmware.vipclient.i18n.VIPCfg         : Formatting cache created.
Formatting cache created.
[YYYY-MM-DDTHH:MM:SS]  INFO   --- [           main] com.vmware.vipclient.i18n.VIPCfg         : Translation Cache created.
Translation Cache created.
Application failed with
com.vmware.evo.sddc.lcm.tools.bundletransfer.exception.BundleTransferUtilityException: Unable to connect to the Proxy Server

Environment

VCF Download Tool 9.0 

Cause

The proxy validation logic expects specific HTTP response codes from the server. Other valid codes may be returned since the introduction of download tokens. The mismatch causes the tool to incorrectly interpret the proxy connection as failed.

Resolution

Workaround 

Use a connection that does not require a proxy.

Resolution 

This issue is resolved in version 9.0.0.0100 of the VCF download tool. VMware Cloud Foundation Download Tool 9.0.0.0100 Release Notes