Issue:
Discovery of device says that it is already found, but when searching on CAPC web UI, the device is not found.
Environment:
Redhat Linux.
CAPC 2.4 through 2.6
Cause:
Data Aggregator has the device information. CAPC should get these device/interface list into netqosportal database.
Corruption in netqosportal database tables will impact updating the list in capc.
Resolution:
1. Take a putty session to CAPC machine
2. Navigate to /opt/CA/MySql/bin with cd command
cd /opt/CA/MySql/bin
3. Run a check and repair of netqosportal database.
mysqlcheck –auto-repair –A
4. Restart CAPC services with the below command. ( Copy paste it as a single line)
/etc/init.d/caperfcenter_sso stop && /etc/init.d/caperfcenter_devicemanager stop && /etc/init.d/caperfcenter_eventmanager stop && /etc/init.d/caperfcenter_console stop &&
/etc/init.d/mysql stop && /etc/init.d/mysql start && /etc/init.d/caperfcenter_sso start && /etc/init.d/caperfcenter_devicemanager start && /etc/init.d/caperfcenter_eventmanager start && /etc/init.d/caperfcenter_console start
5. Refresh CAPC UI and the device should be found properly now.
Additional Information:
If the problem still persists after running above commands or if you face any additional problems during above commands, please contact CA Support.