Default Variable set (CAS Default Variables) missing from Catalog Items in VMware Aria Automation
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Default Variable set (CAS Default Variables) missing from Catalog Items in VMware Aria Automation

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Article ID: 401280

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

The CAS Default Variables variable set contains several essential variables that many client scripts rely on. In some instances, this variable set is found to be missing from catalog items, potentially causing script failures or unexpected behavior.

Environment

  • VMware Aria Automation: Version 8.18.x
  • ITSM Plug-In: Version 8.18.x

Cause

Catalog item variables are not being populated and remain in a continuous loading state. Typically, during the import of catalog items, the CAS Default Variables set is automatically attached. However, if the catalog item is later modified, such as by removing or replacing variable sets this default set may be unintentionally removed. Since many client scripts rely on these variables, their absence can cause the variable section to fail to load properly.

Resolution

There are two recommended solutions to resolve this issue:

Manual Attachment:

  1. Navigate to Maintain Items in ServiceNow
  2. Search for the affected catalog item
  3. Open the item and go to the Variable Sets related list
  4. Click Edit and attach the variable set named CAS Default Variables

Scripted Fix:

Use the provided script, which identifies impacted catalog items and re-attaches the missing CAS Default Variables set automatically.

Additional Information

Engineering has identified this behaviour and is currently working on a permanent fix. The logic to correctly re-attach the default Variable Set during the Update Catalog Item flow will be included in the next product release.

Attachments

variable-script.txt get_app