Datacom DDSDCLM error DDSDCG003P with CC 16

book

Article ID: 40124

calendar_today

Updated On:

Products

CA Datacom

Issue/Introduction

CA Datacom DDSDCLM utility run in preparation for CA Datacom/DB Version 14.0 MUF upgrade to version 15.1 or 15.0 received error DDSDCG003P and CC 16:

 DDSDCG003P       BASIS MODULE DD150SD NOT FOUND IN LOAD LIBRARY CONCATENATION  

Cause

The DDSDCG003P error message is issued when the wrong version "vvv" identifier in the -SDC control statement in the SYSIN as it tries to execute the release dependent load module.

Environment

Release: 14.0  15.0  15.1 

CA Datacom/DB

z/OS

Resolution

If running 15.1 or 15.0 DDSDCLM to check a MUF running under 15.1 or 15.0, the version should be "150" instead of "140":

//SYSIN DD *
-USR DATACOM-INSTALL,NEWUSER 
-SDC  150,PROD                
/*      
 

If running 14.x DDSDCLM to check a MUF running under 14.0 in preparation for upgrade to 15.x, the version should be "140" instead of "150":

//SYSIN DD *
-USR DATACOM-INSTALL,NEWUSER 
-SDC 140,PROD                
/*                          

 

Additional Information

The related DDSDCLM job for 15.1 or 15.0 is INSTJCL member ADSDC15.

The related DDSDCLM job for 14.0 is INSTJCL member ADSDC14.

Refer to CA DATACOM CORE 15.1 section "DDSDCLM - Comparing DATA-DICT Prior to Upgrading"
http://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-mainframe-software/database-management/ca-datacom/15-1/using/ca-datacom-datadictionary-batch-facilities/ddsdclm-comparing-data-dict-prior-to-upgrading.html