SQL Plugin fails to load in Aria Automation Orchestrator due to stale connections and slow SQL Server response
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SQL Plugin fails to load in Aria Automation Orchestrator due to stale connections and slow SQL Server response

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Article ID: 401202

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • When requesting new deployments from VMware Aria Automation backed by Orchestrator workflows leveraging the SQL plugin, catalog resources may fail to load, displaying a persistent loading symbol.
  • Users may also experience delays in response time when trying to expand the SQL endpoints inventory from within the plugin.
    • Despite the slowness from the application layer, connections from external tools to the same Microsoft SQL Server host respond but may show some performance degradation with slow responses.
  • This behavior persists after restarting services in the affected Aria Automation stack.
  • This can also occur when trying to remove and re-add Databases  using  the "Remove a Database"  and  "Add a Database"  workflows respectively.
    • This should reflect in the UI:
    •  "Remove a Database"  
    • Also it shows the same in  the logs ("/services-logs/prelude/vco-app/file-logs/vco-server-app.log")

Environment

VMware Aria Automation 8.x

VMware Aria Automation Orchestrator 8.x

Cause

Several outdated, broken, or misconfigured database connections were present in the SQL plugin configuration. These, combined with a slow-responding SQL server, resulted in cumulative delays during plugin inventory collection. Eventually, this exceeded Automations internal proxy timeout limit, preventing the plugin from loading.

Resolution

Improvements to handling invalid connections will be provided in a future release.

Workaround:

  1. Identify and remove connections that:
    1. Use invalid credentials.
    2. Target unreachable or decommissioned SQL hosts
    3. Are not required in the current environment.
  2. Retain only known-good and validated connection entries.
  3. Confirm that plugin inventory is accessible at:
    Orchestrator > Inventory > SQL Plugin.

Note: If you identify any performance issues with external tools when connecting to this external database, it is recommended to contact your database owner or vendor to review performance tuning improvements to speed up these query times. As a long-term recommendation, monitor SQL Server response time and evaluate network latency between the Aria Automation environment and external database systems.