Error "Unknown error has occurred" when trying to view incidents that were filtered via a role
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Error "Unknown error has occurred" when trying to view incidents that were filtered via a role

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Article ID: 401171

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Updated On:

Products

Data Loss Prevention Cloud Service for Email

Issue/Introduction

You see the error message "Unknown Error has occurred" when trying to view incidents.  This is when the user is added to a role where the incidents are filtered.

Environment

16.0.2

Cause

This can happen if you have a role where there is a filter used to only display incidents by the incident IDs.  For example:

This is caused by the DLP system saving multiple incidents as one entry instead of multiple.  When you add in multiple entries for incidentid, they need to be separated by a new line.  If you use comma as a seperator, it will save them as one entry and cause the unknown error in the console.

Resolution

This is targeted to be addressed in DLP 25.1

Workaround:

Put each incidentid on a new line and not separated by a comma.  Please note that after you save the role, all the incidentid's will be separated by a comma.  If you edit this list, you will have to remove all the commas and make sure each incidentid is on a new line.