PNIC and device configurations do not match for transport node .
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PNIC and device configurations do not match for transport node .

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Article ID: 401079

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Updated On:

Products

VMware NSX

Issue/Introduction

While trying to connect the edge transport node's fp-eth interface to a port group we see the following error 

Error is seen even though the port group is accessible to the edge 

We also see the following entries in the nsxapi logs of the NSX manager

 

Environment

VMware NSX 

 

Cause

The issue is caused because the Edge is referencing an Esxi host that is no longer present in vcenter or running on a Datatstore that is no longer accessible to the Esxi hosts in the vcenter

Execute the api GET /api/v1/transport-nodes/{transport-node-id}/node  

Verify if the Esxi host and the Datatsore information from the above API call match in the vcenter UI. If the host and datastore information in vcenter ui and api output do not match, try the steps mentioned in the "Resolution" section and if that does not fix the issue contact  Broadcom Support 

 

Resolution

If there is a mismatch in the output of the API call and the vcenter UI, execute the POST /api/v1/transport-nodes/{transport-node-id}?action=refresh_node_configuration&resource_type=EdgeNode  to refresh the edge configuration 

Note: Place the edge in maintenance mode before executing the above command