vCenter reports an alarm "Host IP Address Conflict Detected"
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vCenter reports an alarm "Host IP Address Conflict Detected"

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Article ID: 400971

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Updated On:

Products

VMware vSphere ESXi 8.0

Issue/Introduction

An alarm "Host IP Address Conflict Detected" is reported at vCenter level or at ESXi hosts' cluster level.

As per /var/log/vmware/vpxd/vpxd.log

YYYY-MM-DDTHH:MM:SSZ error vpxd[05750] [Originator@6876 sub=InvtId] Detected IP [:#.#.#.#] conflict between host [<host-name>] (moId:host-####) nic:NetworkInfo.vnic[4].ipAddress and entity [<host-name>] (moId:host-####)
YYYY-MM-DDTHH:MM:SSZ warning vpxd[05977] [Originator@6876 sub=InvtHostCnx opID=HeartbeatStartHandler-29670d64] Host IP address conflict detected. [vim.HostSystem:host-#####,<host_name>.com] is trying to change IP from <host_name>.com to #.#.#.#. New IP is already used by <Host ##>

Environment

  • VMware vSphere ESXi 7.x
  • VMware vSphere ESXi 8.x

Cause

This IP address conflict can occur due to:

  • Another ESXi host or physical device using the same IP address.
  • A DHCP server mistakenly assigning the same IP address to multiple devices (if static IP addresses are used incorrectly in a DHCP-managed network).
  • Manual IP address misconfiguration or a network management error.
  • Renaming an ESXI host without first placing it in Maintenance Mode and disconnecting/removing it from vCenter Server inventory.

Resolution

Option 1: Assign a new static IP address

  • Log in to the ESXi host using either the DCUI (Direct Console User Interface) or the vSphere Host Client.
  • Navigate to Networking > TCP/IP configuration.
  • Select the current management network (usually Management Network) and click Edit.
  • Update the IPv4 settings with a new, unused static IP address.
  • Save the changes and verify that the host is accessible with the new IP.

Option 2: Enable DHCP

  • Log in to the ESXi host using the DCUI or the vSphere Host Client.
  • Navigate to Networking > TCP/IP configuration.
  • Select the management network and click Edit.
  • Change the IPv4 settings from Static to DHCP.
  • Save the changes and confirm that the DHCP server has assigned a valid, unique IP address.

Refer Configuring VMware ESXi Management Network from the direct console

Additional Information

For more information about ESXi IP conflicts refer this Duplicate IP address detected

If the alarm was triggered because of and improper renaming process for an ESXi host, the alarm can be Acknowledged and Reset to Green.  Subsequent disconnects/reconnects will not trigger the alarm.