"Windows VMs Do Not Display Disk Serial Numbers, Causing Migration from VMware to Azure Cluster to Fail"
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"Windows VMs Do Not Display Disk Serial Numbers, Causing Migration from VMware to Azure Cluster to Fail"

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Article ID: 400924

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Updated On:

Products

VMware vSAN

Issue/Introduction

Symptoms:

  • During the migration from a VMware environment to an Azure cluster using Azure migration tools, the migration process failed.
  • The Microsoft team identified that the issue was caused by the guest operating system not displaying the disk serial number, which is a required parameter for a successful migration

Below is the blank output observed on the guest operating system when the command to identify the disk serial number was executed.

Environment

VMware vSphere 7.x
VMware vSphere 8.x

Cause

If the disk.enableUUID parameter is set to true on the vmx, the guest operating system should be able to retrieve the disk serial number without any issues, as this information is stored in the VMDK descriptor file. Unless the UUID within the VMDK is in an incorrect format, there should be no blocking issue from the VMware side. 

Resolution

Workaround:

  • It is recommended to attempt recreating the VMDK descriptor by following the steps outlined in the knowledge base article.
    Recreate the VMDK descriptor
  • If recreating the descriptor does not resolve the issue, proceed with cloning the virtual machine.