NSX Edges and BareMetal Edges network failover does not succeed with reports of BGP sessions being down
search cancel

NSX Edges and BareMetal Edges network failover does not succeed with reports of BGP sessions being down

book

Article ID: 400904

calendar_today

Updated On:

Products

VMware NSX

Issue/Introduction

When attempting to perform a test network failover or if a true network failure occurs and failover is needed this process fails. While investigating the NSX Manager UI, it is seen that BGP neighbors are listed as "down" and Edges may report "MPA Connectivity Down". 

Environment

NSX 4.2.1.3

Cause

Below are a few of the more common reasons for the failover to be unsuccessful (though this list is not exhaustive):

  • Incorrect uplink profile configuration
  • Incorrect uplink profile assigned to the correct transport zones
  • Incorrect physical network configurations (for more details on this please work with your hardware vendor)
  • Limited number of physical NICs available in the environment

Resolution

  1. Ensure that the teaming policies have:
    • More than one uplink associated with Active Uplinks

              OR

    • There is at least one uplink associated with Active Uplinks and at least one uplink associated with Standby Uplinks
  1. Ensure that within the VLAN Transport Zone the the Edges/BareMetal Edges have the failover configured Uplink Policy defined. For more information please review Configure Named Teaming Policy

NOTE: If your physical NICs are configured to be in an LACP configuration, please refer to Link Aggregation Groups

 

 

 

Additional Information

For further configuration assistance please review:

Administration Guide