Update certificate request for cloud account failed
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Update certificate request for cloud account failed

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Article ID: 400868

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

After a signing CA certificate has expired and the vCenter machine SSL certificates were updated as described in this KB (1), there is still an error when trying to validate cloud accounts in Aria Automation

  • The vco-app scripting log may contain an entry such as: Request error Update certificate request for cloud account with id <hash> failed. Error : NotAfter: Fri Jun 06 12:42:47 GMT 2025
  • The cloud account page in the UI has an error message such as: Endpoint validation failed during health check: FAILED with NotAfter: Fri Jun 06 12:42:47 GMT 2025
  • The status may also show "Unavailable for deployment".

(1) Replace vCenter Machine SSL certificate Custom Certificate Authority Signed Certificate

Environment

Aria Automation 8.18.x

Cause

If third-party certificates are used in the environment, a trusted root certificate must be added to the certificate store using the vSphere Client.

Resolution

Follow the documentation (1) to update the TRUSTED_ROOTS store with the new signing CA.

(1) VMware vSphere 8.0 - Add a Trusted Root Certificate to the Certificate Store Using the vSphere Client