"Unable to get historical data import status. Check server status" error when logging into vCenter Appliance Management Interface (VAMI)
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"Unable to get historical data import status. Check server status" error when logging into vCenter Appliance Management Interface (VAMI)

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Article ID: 400863

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

When logging into the vCenter VAMI using an AD user account after user (or security group containing that user) that was added to vCenter SSO with Global Permissions and the Administrator role, there is an error "Unable to get historical data import status. Check server status" across the top of the browser and status information is missing or listed as "Unknown":

Environment

vCenter Server 7.x
vCenter Server 8.x

Cause

The cause is due to insufficient permissions granted to the AD account.  Adding an AD user (or group) to vCenter SSO with the Administrator Role and Global Permissions allows that user or group to perform administrator operations on objects managed within vCenter Server (eg: hosts & clusters) but does not allow for VAMI operations.  The SystemConfiguration.Administrators SSO group has a complete privileges to access the local appliance config through the VAMI.  

Resolution

Explicitly add the AD user or group to the SystemConfiguration.Administrators SSO group to be able to view the stats within the VAMI and perform other operations.

Additionally, the AD user or group could also be added to the vsphere.local/Administrators group, which, by default is a member of the SystemConfiguration.Administrators group, however, this is not considered a best practice from a security perspective.

Additional Information

For more information about groups within vCenter SSO domain, please see: Groups in the vCenter Single Sign-On Domain