Fault in Avi UI - "Inoperable 'xxx' Pulse Opt-in. Please deploy a valid SaaS Addon license."
search cancel

Fault in Avi UI - "Inoperable 'xxx' Pulse Opt-in. Please deploy a valid SaaS Addon license."

book

Article ID: 400862

calendar_today

Updated On:

Products

VMware Avi Load Balancer

Issue/Introduction

The following faults are seen in the Avi UI:

  1. Inoperable 'enable_ip_reputation' Pulse Opt-in. Please deploy a valid SaaS Addon license.
  2. Inoperable 'enable_pulse_waf_management' Pulse Opt-in. Please deploy a valid SaaS Addon license.

Example screenshot of the controller fault:

Cause

This particular controller fault can occur in deployments that meet all of the following criteria:

  1. Cloud Services Connection: The Avi Controller is connected to the Avi Cloud Services portal.
  2. License Tier: The deployment is licensed for the Enterprise tier.
  3. Proactive Features Enabled: One or more of the following features, which are opted into via Avi Cloud services, are active:
    • IP Reputation
    • WAF Management (including WAF signature updates)

If your environment matches all three of these conditions, you may be susceptible to this fault.

Resolution

The resolution for this configuration fault depends on your Avi version. Please identify which version you are running and follow the appropriate guidance below.

 

For Avi Versions 30.2.x and 31.1.1:

On these versions, the fault message is displayed erroneously and does not have any functional impact.

  • You can safely ignore this fault.
  • A permanent fix for the incorrect fault message will be included in future Avi versions.
  • Workaround: If you wish to clear the fault message, please contact Broadcom Support to obtain and apply a legacy Avi SaaS Add-on license.

 

For Avi Versions 22.1.x and 30.1.x:

On these versions, you must either switch your license tier or apply an add-on license to enable Pulse opt-in functionality and clear the fault.

  • Option 1: Contact Broadcom Support to obtain and apply a legacy SaaS add-on license.
  • Option 2: Switch your license tier to Enterprise with Cloud Services by following the procedure below.

Procedure: How to Switch to the Enterprise with Cloud Services Tier

  1. Upload License Keys to the Avi Cloud Console

  2. Deregister the Controller from Cloud Services

    • In your Avi Controller UI, navigate to Administration > Cloud Services.
    • Click the DEREGISTER CONTROLLER button and confirm the action. This temporarily disconnects the controller from the cloud portal.
  3. Change the Active License Tier

    • Navigate to Administration > Licensing.
    • Click the gear icon (⚙️) to access the settings.
    • From the dropdown menu, select the Enterprise with Cloud Services Tier.
  4. Re-register the Controller

    • Return to Administration > Cloud Services.
    • Click the REGISTER CONTROLLER button to re-establish the connection to the Avi Cloud Console.

Once the controller successfully re-registers, the configuration fault should be cleared.