CA-NIM-SM request to Service Desk Manager Failing
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CA-NIM-SM request to Service Desk Manager Failing

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Article ID: 400855

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Updated On:

Products

CA Service Management - Service Desk Manager

Issue/Introduction

When trying to make a call to Service Desk Manager via Web Services REST API, the following error is received:

"Error": {
        "ErrorCode": 110,
        "ErrorMessage": "Invalid CI type ",
        "HTTPResponseCode": "BAD_REQUEST",
        "HTTPResponseCodeValue": 400
    }
}

Environment

Service Desk Manager 17.4.x

NIM-CA for Service Management

Cause

There is a syntax error in the request

Resolution

The URL is case sensitive so if you have the following:

curl --location 'https://<SERVER_URL>:<PORT>/ca-nim-sm/api/v2/request/cr:<OBJECT_ID>/comment' \

This URL will not work. 

It should be corrected as:

curl --location 'https://<SERVER_URL>:<PORT>/ca-nim-sm/api/v2/Request/cr:<OBJECT_ID>/comment' \

Note that the request section of the original query is updated to Request and this should be successful