In Office 365 using Azure connector Once Account Template is updated with Distribution List mapping, user access does not update accordingly In 14.5 SP1 CHF1
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In Office 365 using Azure connector Once Account Template is updated with Distribution List mapping, user access does not update accordingly In 14.5 SP1 CHF1

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Article ID: 400839

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Updated On:

Products

CA Identity Suite CA Identity Manager

Issue/Introduction

After upgrade to  14.5 SP1 CHF1 and applied the Remote connector related Hotfix, however in Azure connector once Account Template is updated with Distribution List mapping, user access does not update accordingly after account Template synchronization with Accounts.

Environment

Identity Manager 14.5 SP1 CHF1 / Identity Suite  14.5 SP1 CHF1 

Cause

CHF1 documentation under Enhancement section mentions "A Change in the Azure Group Object Naming Format" which require running

UpdateAzurePoliciesUtility.bat/sh utility after the upgrade.

If this is not done issue as described above will occur.

Resolution

Follow the steps below:

1. Ensure that all components, including the remote connector server, are updated to the same version and hotfix level as the main machine or Virtual Appliance.

2. Run the UpdateAzurePoliciesUtility.bat/sh utility as described here.

 

Additional Information

The purpose of UpdateAzurePoliciesUtility.bat/sh utility is to update the Account Template group objects. When executed, the utility primarily performs the following actions:

  1. Updates the group object names to the format "displayname::id" when a match is found between IM and O365.

  2. Leaves group objects unchanged if no match is found.


If there are any issues with running the utility, reach out to support, as we can provide the utility with extended debugging.