Users unable to access DevTest portal after migration of roles.
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Users unable to access DevTest portal after migration of roles.

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Article ID: 400831

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Updated On:

Products

Service Virtualization

Issue/Introduction

In the common IAM for 9 Registries, new roles were created and users were assigned these one of these new roles. Then, other than the new roles assigned to the users, all other roles where deleted via IAM console.

Above changes were tested successfully in one of the registry where the roles definition was completed.

The users are not able to see any details after login into multiple DevTest portals.

 

Environment

DevTest 10.7.2 and above

Cause

The access issue happened for the registries where the role definition was pending for the newly created roles in the common IAM.

Resolution

Similar role definition had to be done in all other Registry Portal consoles for newly created roles. 

In order to resolve the issue, in the databases of all the impacted Registries, the permission(activity_id) for "Users & Role administration" was identified and assigned to newly created <admin> role in ACL_ROLES_ACTIVITIES table.

This allowed the users with <admin>  role to login to Portal and update both the new roles as needed and allowed the users with these roles to access DevTest.