Cannot see Report Templates in the WCC Reporting tab. What needs to be configured to get reports available in WCC?
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Cannot see Report Templates in the WCC Reporting tab. What needs to be configured to get reports available in WCC?

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Article ID: 400728

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Updated On:

Products

Autosys Workload Automation

Issue/Introduction

WCC Reporting tab has no templates available in the left pane nor any reports. What needs to be configured to get reports available in WCC?

Cause

The Logged in user is missing permissions in EEM for the Report Template Access access policy.

To verify this:

  • login to EEM UI  using WCC0004 application and then navigate to  Manage Access Policies ->  Permission Check using:

resourceclass:   Report Template Access
Action:   <any report is fine in the dropdown>
Resource:   *
Identity:   <userid of the user logged into WCC>

  • Click Run Permission Check
  • In the bottom pane, it should show ALLOW (in green) if it is permitted, if not, a DENY if it is not allowed

For the customer in this case, the above showed Denied in Production environment where they could not see the reports, while it showed as Allowed in Development env environment where the reports show up fine.

Clicking on the Debug checkbox showed that the logged in user belonged to a group called  Commanders (in Development) but not in Production environment

Resolution

  • Add the logged in user to the Dynamic User Group, commander.
  • Save.
  • Logout of WCC and logged back in.