SRM IP change issue at Failover & Failback
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SRM IP change issue at Failover & Failback

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Article ID: 400716

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Updated On:

Products

VMware Live Recovery

Issue/Introduction

When running a Recovery Plan, a VM is not properly customizing its IP address despite no errors being thrown in the Recovery Plan report:

Additionally, the 'Customize IP' step is missing from the 'Power on' steps:

Environment

VMware Live Recovery 9.0+

VMware Site Recovery Manager 8.6+

Cause

If the 'Customize IP' step is missing, this indicates that the IP customization configuration was not set up properly.

Most likely, VMware Tools is not enabled in the VM Recovery Properties

VMware Tools needs to be enabled for IP customization to execute.

Resolution

Ensure that VMware Tools is enabled and has a time-out value set in the VM Recovery Properties.

To enable and set a time-out value for VMware Tools, follow the path below:

  • Open the Site Recovery UI
  • Navigate the Recovery Plans tab
  • Select your Recovery Plan
  • Click on the Virtual Machine tab
  • Select a VM
  • Click on the Configure Recovery action item
  • Expand the 'Startup Action' dropdown

If the VMware Tools checkbox is not checked, go ahead and enable it.

The default value will be set to 5 minutes.

If the VMware Tools checkbox is checked, but the values are set to 0 minutes and 0 seconds, this is the same as it not being enabled.

*Note: You can modify the default value for the VMware Tools time-out value. This is controlled by an Advanced Setting under 'Recovery'. The advanced setting is 'recovery.powerOnTimeout'

 

Once VMware Tools is enabled, then you will see the 'Customize IP' recovery step added to the 'Power On' steps in the Recovery Plan: