Windows Event logs generate “A timeout (30000 milisecond) was reached while waiting for a transaction response from the VMtools service.”
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Article ID: 400683
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Updated On:
Products
VMware vSphere ESXi
Issue/Introduction
VMTools service in the Windows Operating System fails to start with a timeout error and with Event ID 7011.
Below event logs are generated in the Windows System Event viewer.
Environment
VMware Tools
Cause
This issue may occur, when
Configuration directives within Active Directory Group Policy (GPO) have the potential to unintentionally compromise the operation of the tools service.
The operational integrity of the tools service can be inadvertently affected by Active Directory Group Policy settings.
If the VMTools version is incompatible/lower.
Resolution
Option1: To test and confirm if a Group Policy Object (GPO) is causing the issue with the VMTools service, follow these steps:
Isolate VM: Create a new Organizational Unit (OU) in Active Directory and ensure it has no GPOs linked to it. And move the computer object of an affected guest VM into this new OU.
Apply Policy: On the Windows Guest OS VM, open an elevated command prompt and execute gpupdate /force
Reboot & Verify: Reboot the VM. Upon restart, check if the VMTools service now starts successfully and check if the Event ID 7011 w.r.t VMTools still occurs.
Identify GPO (if successful): If the service starts, run an RSOP (Resultant Set of Policy) report on both this newly isolated VM and a VM still residing in the original, problematic OU. Compare these reports to identify the specific GPO interfering with the VM tools service.