vCenter upgrade failed in the Past-Install phase with error: "Exception occurred in postInstallHook for B2B-pathing. Please check the logs for more details. Take corrective action and then resume."
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vCenter upgrade failed in the Past-Install phase with error: "Exception occurred in postInstallHook for B2B-pathing. Please check the logs for more details. Take corrective action and then resume."

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Article ID: 400647

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • Upgrade from "vCenter Server 8.0 Update 3d" to "vCenter Server 8.0 Update 3e" failed in the Past-Install Phase with error showed in below screenshot:


  • All certificates are in place, none expired
  • From Patch-runner.log, we see the below:

stderr: Error executing start on service vtsdb. Details {  
    "detail": [  
        {  
            "id": "install.ciscommon.service.failstart",  
            "translatable": "An error occurred while starting service '%(0)s'",  
            "args": [  
                "vtsdb"  
            ],  
            "localized": "An error occurred while starting service 'vtsdb'"  

  • At the location /var/log/vmware/vstats in the vstats-stdout.log logfile you see lines similar to:

<timestamp>  PANIC   vcrecoverable/vcrecoverable.go:126      Error while getting providers.  {"vStats": "MVP", "PANIC": "Error while getting providers."}
vstats/util/vcrecoverable.handlePanic
        bora/vpx/vstats/vstats-svc/src/vstats/util/vcrecoverable/vcrecoverable.go:126
runtime.gopanic

Environment

VMware vCenter Server 8.0.3

Cause

Following an upgrade of vCenter to 8.0.3 may discover that following services are in stopped state:

  • vstats(VMware vStats Service)
  • vtsdb (VMware vTsdb Service)

VMware Engineering is currently still investigating the issue.

Resolution

Please follow either the workaround mentioned in this KB: https://knowledge.broadcom.com/external/article/378129/

Additional Information