Error: "There was a problem parsing the submitted installation file." when Software import fails
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Error: "There was a problem parsing the submitted installation file." when Software import fails

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Article ID: 400646

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Updated On:

Products

Client Management Suite IT Management Suite Software Management Solution

Issue/Introduction

The following UI error occurs when importing packages with certain file extensions:

There was a problem parsing the submitted installation file.

The following entries are seen in the logs:

Access to the path 'C:\Program Files\Altiris\SoftwareManagement\Temp\fc2a5fb1-b594-4f23-8c9f-132f920ec6aa' is denied.
   [UnauthorizedAccessException @ mscorlib.dll]
   at System.IO.__Error.WinIOError(int, string)
   at System.IO.Directory.InternalCreateDirectory(string, string, object, bool)
   at System.IO.Directory.InternalCreateDirectoryHelper(string, bool)
   at Altiris.SoftwareManagement.Resources.SoftwareInstallationFileResource.GetTemporaryArchiveFolder(Guid, bool)
   at Altiris.SoftwareManagement.Resources.Appx.MsixParser+MsixStringsLocalizer.EnsureResourceFile()
   at Altiris.SoftwareManagement.Resources.Appx.MsixParser+MsixStringsLocalizer.LocalizeString(string)
   at Altiris.SoftwareManagement.Resources.MsixBundleSoftwareInstallationFileResource.GetComponentDetails(string)
   at Altiris.SoftwareManagement.Resources.SoftwareComponentResource.GetInstallInfo(string, ref InstallFileInfo, ref string)

Exception logged from:
   at Altiris.Diagnostics.Logging.EventLog.ReportException(int, string, string, Exception, string)
   at Altiris.SoftwareManagement.Resources.SoftwareComponentResource.GetInstallInfo(string, ref InstallFileInfo, ref string)
   at Altiris.SoftwareManagement.WebApi.Controllers.PackageController.GetInstallFileInfo(InstallationFileInfoRequest)
   at .lambda_method(Closure, object, object[])

Environment

ITMS 8.8

Cause

Product defect.

This problem occurs only with a custom ACC (Agent Connectivity Credential) account without additional permissions.

Resolution

Fixed in ITMS 8.8.1

The workaround is to grant use following NTFS permissions:

  • Full access to [C:\Program Files\Altiris\SoftwareManagement] (or custom install path) for ACC account
  • Read & Execute, List folder Permissions, Read permissions to [C:\Program Files\Common Files\Altiris]

Additional Information