カスタム証明書を使用している環境で li-reset-admin-passwd.sh コマンドを使用したローカル admin アカウントのリセットやアンロックが失敗する
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カスタム証明書を使用している環境で li-reset-admin-passwd.sh コマンドを使用したローカル admin アカウントのリセットやアンロックが失敗する

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Article ID: 400633

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VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

免責事項:これは英文の記事「Resetting or unlocking the local admin account using the li-reset-admin-passwd.sh command fails in environments using custom certificates.」の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。

カスタム証明書を使用している環境で li-reset-admin-passwd.sh コマンドを使用すると以下のようなエラーが発生する

  • FAILED: Unable to get user data. Possible cassandra is down.
  • ERROR: Unable to get salt

さらにコマンドを実行した場合、以下の出力が返ります。

# openssl x509 -noout -purpose -in /usr/lib/loginsight/application/etc/certs/cluster.pem | grep '^SSL \(server\|client\) :'
SSL client : No
SSL server : Yes

Environment

Aria Operations for Logs 8.18

Cause

カスタム証明書への置き換えを行う際、truststore にある証明書も同時に置き換えが行われてしまうため。
**注:truststore にある証明書は li-reset-admin-passwd.sh などのトラブルシュート用コマンド内のみで使用されるものです。

Resolution

今後のリリースで修正予定です。

Workaround:

truststore の証明書をデフォルト証明書で置き替えることで対応します。

sed -n '/-----BEGIN.*CERTIFICATE-----/,/-----END.*CERTIFICATE-----/p' /usr/lib/loginsight/application/etc/certs/default.pem > /storage/core/loginsight/cidata/cassandra/config/cacert.pem