Issues when clicking NSX group "Where Used" link and then clicking a rule
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Issues when clicking NSX group "Where Used" link and then clicking a rule

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Article ID: 400562

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Updated On:

Products

VMware vDefend Firewall VMware vDefend Firewall with Advanced Threat Prevention

Issue/Introduction

  • Under Inventory > Groups When clicking the "Where Used" link for a particular group, then selecting any of the Distributed Firewall (DFW) rule links, you may experience any of the following symptoms:
    • Endless spinning wheel. Only by clicking the browser refresh button is the UI restored:



    • The UI returns to the Inventory > Groups page and nothing else happens
    • The UI remains in the "Where Used" menu and nothing happens. 

 

 

Example:

  • There are two groups named "Test" with different capitalization. 

 

 

  • When clicking the DFW rule link in the "Where Used" menu for the group named Test_Group (used in the source of DFW rule 1018), the UI runs into issues:

Environment

VMware NSX 3.x

VMware NSX 4.x

Cause

The issue occurs when there are two DFW policy sections with the same name but different capitalization. In this case, the UI is not handling the case-insensitive nature of the Search API, and therefore when clicking the DFW Rule link under the "Where Used" menu, two entries are returned which cannot be processed correctly and the navigation gets stuck.

Resolution

This issue will be fixed in a future release

 

Workaround:

  1. Delete one of the duplicate policies
  2. If you have rules in both policies and cant delete one:
    1. Create a new policy with a non-duplicated name
    2. Create the needed rules within this policy
    3. Delete the original policy with the duplicate name