The sandboxd.log on an ESXi host is constantly logging: "HTTP Connection has timed out while waiting for further requests"
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The sandboxd.log on an ESXi host is constantly logging: "HTTP Connection has timed out while waiting for further requests"

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Article ID: 400544

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

The sandboxd.log on an ESXi host (var/run/log/sandboxd.log) contains the following log entries at regular intervals:

YYYY-MM-DDTHH:MM:SS.212Z In(166) sandboxd[2098897]: [Originator@6876 sub=Default.HTTPService.HttpConnection] HTTP Connection has timed out while waiting for further requests; <io_obj p:0x000000f18dd325a8, h:-1, <UNIX 'vmwLocalSocketSandboxVapi'>, <UNIX 'vmwLocalSocketSandboxVapi'>>, N7Vmacore16TimeoutExceptionE(Operation timed out: Stream: <io_obj p:0x000000f18dd325a8, h:-1, <UNIX 'vmwLocalSocketSandboxVapi'>, <UNIX 'vmwLocalSocketSandboxVapi'>>, duration: 00:00:48.256026 (hh:mm:ss.us))


Please run the below command to verify if the Sandbox Daemon is running: 

/etc/init.d/sandboxd status
Sandbox Daemon is running


If the Sandbox Daemon is not running, please refer to this knowledge base article, as similar log entries can appear when the daemon is stopped: vMotions fail with a general error

VMs can be powered on/off and vMotion operations can be performed without any issues. The above KB describes an issue with the similar logging that causes vMotion and VM power operations to fail.

There are no entries similar to the following found in the hostd.log (/var/run/log/hostd.log), similar logging can be an indication that the Sandbox service may not be functioning correctly:

yyyy-mm-ddThh:mm:ss.us Wa(164) Hostd[2745240]: [Originator@6876 sub=IO.Connection] Failed to connect; <io_obj p:0x0000002c3a809660, h:60, <UNIX ''>, <UNIX 'vmwLocalSocketSandboxVapi'


If you see similar entries to this in the hostd.log, then review the above KB article. 

Environment

ESXi 8.0

Cause

These are benign messages and should not have any adverse affects.

Resolution

These are benign messages and can be ignored.

Please raise a case with the Broadcom Technical Support team if any issues are observed. 

Refer: https://knowledge.broadcom.com/external/article/206567/