AutoSys ServiceNow integration is also causing error CAUAJM_E_00109 SOAP FAULT: SOAP-ENV:Client
search cancel

AutoSys ServiceNow integration is also causing error CAUAJM_E_00109 SOAP FAULT: SOAP-ENV:Client

book

Article ID: 400534

calendar_today

Updated On:

Products

Autosys Workload Automation

Issue/Introduction

AutoSys ServiceNow integration is working intermittently only, and it is generating a CAUAJM_E_00109 SOAP FAULT: SOAP-ENV:Client

Scheduler logs showed errors like this:

[06/08/2025 21:09:46]      CAUAJM_I_40245 EVENT: CHANGE_STATUS    STATUS: FAILURE         JOB: HELPDESK_TEST MACHINE: <server>.<example>.<com> EXITCODE:  1
[06/08/2025 21:09:46]      CAUAJM_I_00117 Service Desk request pending    JOB: HELPDESK_TEST
[06/08/2025 21:09:46]      CAUAJM_I_61015 Help desk request pending for JOB: HELPDESK_TEST RUN_NUMBER: ########.1 STATUS: FAILURE
[06/08/2025 21:09:46]      CAUAJM_E_00108 Service Desk login failure rc = 30
[06/08/2025 21:09:46]      CAUAJM_E_00109 SOAP FAULT: SOAP-ENV:Client
[06/08/2025 21:09:46]      "SSL_ERROR_SSL
[06/08/2025 21:09:46]      error:14090086:SSL routines:ssl3_get_server_certificate:certificate verify failed
[06/08/2025 21:09:46]      unable to get local issuer certificate"
[06/08/2025 21:09:46]      CAUAJM_E_00110 Detail: SSL/TLS handshake failed
[06/08/2025 21:09:46]      CAUAJM_E_00118 Service Desk request failed    JOB: HELPDESK_TEST
[06/08/2025 21:09:46]      CAUAJM_I_40245 EVENT: ALARM            ALARM: JOBFAILURE       JOB: HELPDESK_TEST MACHINE: <server>.<example>.<com> EXITCODE:  1
[06/08/2025 21:09:46]      CAUAJM_I_40245 EVENT: ALARM            ALARM: SERVICEDESK_FAILURE JOB: HELPDESK_TEST
[06/08/2025 21:09:47]      CAUAJM_I_61017 Help desk request creation successful for JOB: HELPDESK_TEST RUN_NUMBER: ########.1 STATUS: FAILURE TICKET_NUMBER: INC12345678 TICKET_ID: ###############

 

Cause

The Job Definition in this case had both  service_desk=y  and helpdesk:y

For AutoSys ServiceNow integration, we just need helpdesk:y   

service_desk:y  is the old Broadcom Service Desk Manager approach and is no longer relevant for Service Now integration.

Resolution

Update the job definition and remove   service_desk:y  via JIL:

update_job: HELPDESK_TEST
service_desk:
exit

 

Retest again now