Host commission in SDDC Manager fails with error Failed to validate vSAN HCL status
search cancel

Host commission in SDDC Manager fails with error Failed to validate vSAN HCL status

book

Article ID: 400496

calendar_today

Updated On:

Products

VMware SDDC Manager

Issue/Introduction

ESXi host commission in SDDC Manager fails with error Failed to validate vSAN HCL status in the SDDC UI.

In the SDDC Manager logs we see the following: 

/var/log/vmware/vcf/operationsmanager/operationsmanager.log 

 

Checks if the NVMe device(s) in this vSAN cluster is/are compatible with the vSAN configuration type as per vSAN VCG (VMware Compatibility Guide).","testAllEntities":6,"testHealth":"yellow","testDetails":[{"columns":[{"label":"Host","type":"dynamic"},{"label":"Device","type":"string"},{"label":"Device name","type":"string"},{"label":"Used
by vSAN","type":"string"},{"label":"Device certified","type":"*****"},{"label":"PCI ID","type":"string"},{"label":"Use for","type":"string"},{"label":"Supported vSAN Configuration","type":"string"}],"rows":[{"values":["HostReference:##.##.##.##
","vmhba1","t10.NVMe____VO003840KXNZR___________________________3D5C0E490175A000","No","yellow#common.uncertified","*****","vSAN ESA","vSAN"]},

 DEBUG [vcf_om,#################,###] [c.v.e.s.c.c.v.vsan.VsanManagerBase,host-comm-decomm-exec-2] HCL check failed for test NVMe device is VMware certified due to yellow status
ERROR [vcf_om,#############,###] [c.v.v.h.c.s.i.CommissionHostsValidator,host-comm-decomm-exec-2] Host validation failed for Host: [HOST_FQDN]
DEBUG [vcf_om,###############,###] [c.v.v.h.c.s.i.CommissionHostsValidator,om-exec-17] [HOST_FQDN]: VSAN_HCL_VALIDATION_FAILURE
DEBUG [vcf_om,#############,######] [c.v.v.h.c.s.i.CommissionHostsValidator,om-exec-17] Completed validating Host(s).

Environment

VCF 5.2.x

Cause

Disk is not VSAN ESA compatible in the VSAN HCL. 

  • Extract from vSAN HCL file example:
productid": "VO003840KXNZR",
                                "model": "HPE 3.84TB NVMe RI SFF MV SSD",
                                "vendor": "Nvme",
                                "partnername": "Hewlett Packard Enterprise",
                                "capacity": 3840,
                                "partnumber": "P47824-B21, P47824-H21, P47842-B21, P47842-H21,P47846-B21, P47846-K21,P64845-B21, P64845-H21, P64846-B21, P64846-H21, P64882-B21, P64882-H21, P64846-K21, P64882-K21,P47824-K21",
                                "devicetype": "NVMe",
                                "vid": "1344",
                                "did": "51c3",
                                "svid": "1590",
                                "ssid": "03d1",
                                "vsanSupport": {
                                        "mode": [
                                                "vSAN"

 

Note: If the disk was vSAN ESA compatible it would show the following: 

mode":[ "vSAN ESA","vSAN"]

Resolution

Check the the VSAN HCL file for the DISK Model to see what vSAN Support mode is specified.

Link to VSAN HCL:  https://vvs.broadcom.com/service/vsan/all.json